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• 安全注意事项 • 
(使用设备前请阅读本说明。) 

 

使用本品前，请仔细阅读本手册及本手册中提到的相关手册，正确操作并注意安全。 

本手册中给出的说明均是关于本产品的。有关可编程控制器系统的安全说明，请阅读 CPU 模块用户手

册。 

在本手册中，安全守则分为“危险”和“注意”二个等级。 

 

另外根据情况 ! 注意 中的内容也可能导致严重后果。 

请遵照两级注意事项执行，因为它们对人身安全至关重要。 

 

请保留本手册，放于操作人员易于取阅的地方，并应将其交给最终使用者。 

 

[设计说明] 

!  危险 

● 有关正在计算机上运行的 PLC 的数据变化，程序变化，状态控制，在外部配置一个互锁回路以

确保系统的安全。在计算机上的 PLC 进行在线操作的时候，需要考虑由于电缆的连接问题而导

致的通讯异常时的处置方法。 

 

!  注意 

● 请在熟读了本手册及完全确保安全之后将计算机与正在运行的 PLC CPU 连接并进行在线操作

(PLC CPU RUN、强制性的 I/O 操作、RUN-STOP 期间的程序变更或类似操作条件的变更及远程操

作等)。 

另外，PLC CPU RUN 期间的程序变更(在线变更)可能导致一些问题，如有时由于操作条件会造

成程序损坏。应完全理解 GX Developer 操作手册中给出的注意事项之后再使用本设备。 
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前言 

感谢您选择三菱电机的综合 FA 软件 MELSOFT 系列。 

为确保正确使用，请先熟读本手册并完全理解 MELSOFT 系列音序器的功能及性能。 
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关于手册 

以下手册亦与本品有关。 

下表中，请根据实际需要选购。 

 

相关手册 

 

手册名称 手册编号 

GX Developer 版本 8 操作手册(入门篇) 

介绍系统配置、安装方法及 GX Developer 的启动方法。 

 (另售) 

SH-080372E 

GX Developer 版本 8 操作手册 

解释编程、打印输出、监视功能及调试方法等等，GX Developer。 (另售) 
SH-080311C 

GX Developer 版本 8 操作手册(结构文本) 

介绍结构文本(ST)程序的创建方法，打印输出方法等等，使用GX Developer。 
SH-080367E 

QCPU(Q 模式)设计手册(结构文本) 

介绍结构文本语言编程方法。 
SH-080366E 

结构文本(ST)编程指导书 

为初次创建结构文本(ST)者编写，通过样本程序介绍基本操作方法及功能。 
SH-080368E 

 

 

备注 

以上手册被一起收在各软件包的 CD-ROM 中。 

如果希望单独购入时，按印刷的文件可分别获取。 

当发出定单时，请说明在上表中给出的手册的编号(类型代码)。 
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本手册中的简称及总称 

 

本手册中使用下列总称及简称来代表 GX Developer软件包及 PLC CPU 模块。在必须指明具体类型时标明该模

块类型。 

  

总称/简称 说明 

GX Developer SW8D5C-GPPW、SW8D5C-GPPW-A、SW8D5C-GPPW-V 及 SW8D5C-GPPW-VA 的产品类型总称。 

FB 功能块的简称。 

ST 结构文本的简称。 

QnACPU MELSEC-QnA 系列 PLC CPU 的总称。 

QCPU(Q 模式) 
Q00(J)CPU、Q01CPU、Q02(H)CPU、Q06HCPU、Q12HCPU、Q12PHCPU、Q12PRHCPU、

Q25HCPU、Q25PHCPU 及 Q25PRHCPU 的总称。 

ACPU MELSEC-A 系列 PLC CPUs 的总称。包含 QCPU(A 模式)及运动控制器(SCPU)。 

QCPU(A 模式) Q02(H)-A 和 Q06H-A 的总称。 

FXCPU 
MELSEC-FX 系列 PLC CPU.的总称 

(目标 PLC 是 FX0、FX0S、FX0N、FX1、FX2、FX2C、FX1S、FX1N、FX2N和 FX2NC。) 

QnA 系列 当 GX Developer 在 QnACPU 上启动时。 

Q 系列 当 GX Developer 在 QCPU(Q 模式)上启动时。 
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1 概要 

1 概要 

本手册介绍了 GX Developer 版本 7 软件包(以下简称 GX Developer)中编辑功能块(以

下简称 FB)的操作方法 。 

FB 以外的功能解释，请参阅“相关手册”中的手册。 

 

1.1 什么是功能块(FB)? 

FB 是用来把反复使用的梯形图块转换成通用部件(FB)并在顺控程序中使用的功能，这

种功能块(FB)可以在顺控程序中反复使用，不仅提高了程序开发的效率，也减少了编

程中的错误，从而改善了程序质量。 

 

 
 

*1: GX Developer 执行写入 PLC 时把已编译的顺控程序写入到 PLC CPU 中。 

在执行写入 PLC 时选中“写入标签程序(ST、FB、结构)”后，在再次执行“从 PLC 读取”时可再现

FB。 

 

 

 1 
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1.2 特点 

FB 有以下特点。 

(1) 把程序转换成部件 

把标准程序显示为一个独立的块，从而提高了程序的再利用性及可读性，使编译

与调试更容易。这样保证了可以轻松编写大规模程序。 

 

(2) 统一的程序质量 

重复利用标准程序的部件提供了统一的程序质量，这与程序开发者的技术水平无

关。同时也防止了再次使用时的编程错误。 

 

(3) 操作方便的编辑功能 

通过拖放操作可在顺控程序中轻松使用 FB。 

 

1.3 创建 FB 所用窗口的结构和名称 

本节介绍创建 FB 所用窗口的结构与名称。 

 

(1) 创建 FB 定义程序(FB 定义窗口)的窗口 

本窗口用来编辑以梯形图格式或以列表格式创建的 FB 定义程序。 

在(2)中的 FB 变量设置窗口中，标识定义了变量类型、软元件类型等等。 

 

<梯形图程序> 
 

 

 

 1  
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<ST 程序> 
 

 
 

(2) 创建 FB 定义标识(变量)的窗口 

(FB 变量设置窗口) 

本窗口用来定义 FB 定义中所用到的标识。 
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(3) 创建顺控程序的窗口 

(顺控程序窗口) 

本窗口用来编辑粘贴了 FB 的顺控程序。 

以梯形图格式创建顺控程序，不能用列表格式。 
 

 
*1: 未编译完的顺控程序步号显示在圆括号内，也就是 :(步号)。 

编译完成后，步号显示时不带圆括号。 

编译完成后，步号可能会改变。 

 

名称 说明 

FB 标签 标签显示了工程数据列表中的 FB 定义。 

FB 变量 FB 定义中使用的标识。 

FB 定义 成对的程序和其 FB 定义。 

FB 定义窗口 编辑 FB 定义程序的窗口。 

FB 定义程序 在 FB 定义窗口创建标识的程序。 

FB 变量设置窗口 用来设置 FB 变量的窗口。 

工程标签 在工程数据列表中显示工程信息。 

FB 粘贴到顺控程序上的功能块。 

FB 区 表示粘贴到顺控程序上 FB 的矩形符号。 

输入梯形图区 在 FB 区的左边的输入梯形图。 

输出梯形图区 在 FB 区的右边的输出梯形图。 

顺控程序窗口 用于编辑粘贴了 FB 的顺控程序的窗口。 

FB 定义名 显示在 FB 标签中的 FB 定义名。 

FB 名 粘贴到顺控程序上的 FB 的名称。 

相同的 FB 定义粘贴到梯形图后名称不同。 

FB 窗口 用于读取或监视粘贴了 FB 的顺控程序中程序。 

FB 窗口不能用于写程序。需要写程序时应使用 FB 定义窗口。 
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1.4 使用 FB 之前您应该了解什么 

与在普通的顺控程序中一样，FB 利用标识以梯形图或列表格式在梯形图程序中或在 ST

程序中创建程序。 

因此，在创建 FB 之前，应充分理解在 GX Developer 上利用标识创建顺控程序的方

法。 

有关在 GX Developer 上创建顺控程序的详细操作，请参阅相关手册中“GX Developer

版本 8 操作手册”。 

 

 

1.5 规格 

 

1.5.1 兼容 CPU 

下列型号的 CPU 可使用 FB。 
 

PLC 系列 类型 

QCPU(Q 模式) 
Q02CPU、Q02HCPU、Q06HCPU、Q12HCPU、Q25HCPU、Q12PHCPU、

Q25PHCPU、Q12PRHCPU、Q25PRHCPU 

QnACPU 
Q2ASCPU、Q2ASCPU-S1、Q2ASHCPU、Q2ASHCPU-S1、Q2ACPU、 

Q2ACPU-S1、Q3ACPU、Q4ACPU、Q4ARCPU 

ACPU、QCPU(A模式)、FXCPU及 PLC系列运动控制器均不能使用FB。 

 

1.5.2 FB 规格及使用注意事项 

以下是 FB 的规格以及使用 FB 时的注意事项。 

 

(1) 创建 FB 定义程序 

(a) 规格 
 

项目 规格 

程序容量 2048 步(对于 ST 程序:FB 定义转换、最多 2048 步) 

可用作软元件标识的数量 500 个. 

·输入变量+I/O 变量 = 24 个 

·输出变量+I/O 变量 = 24 个 

(至少需要一个输入变量和一个输出变量) 

·输入、输出和 I/O 变量以外的其它标识用作内部变量。 

编程语言 梯形图、列表、ST 
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(b) 注意事项 

1) 在 FB 内不能使用 FB。 

2) 变址修饰不能使用标识。 

要制作变址修饰，请使用实际软元件作为目标软元件。 

3) 如果用内部变量存储一个除法指令的结果，那么其余数不能用于控制，

因为除法的余数不能赋值给标识。 

若想把除法指令的余数用于控制，请使用实际软元件作为存储除法结果

的软元件。 

4) 因为数字软元件最多可存储两个字数据，若指令超过三个字则不能从外

部输入。 

要从外部输入三个或更多字的数据，应使用实际软元件作为存储输入值

的软元件或创建多个输入指令。 

5) 因为数字软元件最多可存储两个字数据，如果指令结果有三个或以上字

则结果不能输出。 

要输出三个或以上字数据，应使用实际软元件作为存储结果的软元件。 

 

(2) 创建包含 FB 的顺控程序 

(a) 规格 
 

项目 规格 

可创建顺控程序的语言 梯形图、ST 

可粘贴的 FB 
已经编译的 FB 

若试图粘贴没有编译的 FB，GX Developer 就会显示一个出错信息。 

可贴粘到梯形图块上的 FB

数量 

1 个。 

FB 上的输出不能与其它 FB 上的输入直接相连。若想连接多个 FB，

先用线圈接收 FB 的输出，然后将线圈的触点连接到其它 FB 的输

入。 
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(b) 注意事项 

1) 在输入梯形图区和输出梯形图区中不能使用换行连接。 

 
 

2) FB 不能在 SFC 及 MELSAP-L 程序中使用。 

 

3) 如果 FB 的软元件类型与输入或输出梯形区的不同，GX Developer 就会

显示一个出错信息。 

以下是 FB 软元件的五种类型。 

·BOOL : ON/OFF 数据. 

·INT : 16 位数据. 

·DINT : 32 位数据 

·REAL : 32 位浮点数据 

·STRING : JIS8 代码的字符串数据 

例如，将一个触点与 FB(软元件类型为一个字)的输入连接，则会引起错

误。 

 

4) FB 定义可自动地将软元件分配给程序中使用的标识。当创建顺控程序

时，请避免自动分配软元件。 

与本地软元件一样，自动分配软元件应按照自动分配软元件设置进行设

置，下列软元件范围的缺省值为: 

·字软元件 : D6144 至 D12287 

·位软元件 : M4096 至 M8191 

·定时器 : T64 至 T2047 

·计数器 : C512 至 C1023 
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备忘录 
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2 编辑 FB 的一般步骤 

下面的流程图给出了从创建工程到调试使用 FB 的一般步骤。 

 

(1) 使用 FB 创建新的顺控程序 
 

 
 

 

 

要点  

该通用步骤仅供参考。 

可以不按上述顺序执行每个操作。 
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备忘录 
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3 使用 FB 创建顺控程序 

以下说明了使用 FB 创建顺控程序时的操作。 

本章讲述了创建下列 FB 定义(程序，FB 变量)及顺控程序的过程。 

 

(1) FB 定义(程序) 

 

 

(2) FB 定义(FB 变量) 

 

 

(3) 顺控程序 

 

本章所述的顺控程序的样本工程(qcpu_fb)包含在本品的 CD-ROM 中。 

安装 GX Developer 后，选择[Project]-[ Open project]来打开样本工程。  
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按如下描述的步骤处理 FB。 

1) 在工程的 FB 标签中创建 FB 定义。 

2) 创建 FB 定义的程序及 FB 变量。 

3) 把登记到 FB 标签的 FB 定义粘贴至顺控程序中。 

4) 粘贴 FB 后，创建包含 FB 的梯形图块。 
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3.1 为 FB 创建新工程 

[设置目的] 

为新建 FB 工程，设置必要的 PLC 系列、PLC 类型及工程名。 

 

[操作步骤] 

选择[Project]  [New project]或单击  (  Ctrl  +  N  )。 

 

[对话框] 
 

 
 

[说明] 

1) PLC 系列 

对于 PLC 系列，选择 QCPU(Q 模式)或 QnACPU。 

2) PLC 类型 

对于 PLC 类型，选择使用的 CPU 类型。 

3) 程序类型 

创建 FB 时，选择梯形图程序或 ST 程序。 

4) 标识设置 

设置 FB 时，选择“使用标识”。 

5) 工程名设置 

指定一个工程名存储已创建的数据。 

创建程序前，指定工程名时应选中复选框。 

程序创建前后都可以指定工程名。 

数据创建后指定工程名时，使用[另存为]菜单。 

6) 驱动器/路径 

设置工程保存路径。(已保存) 

只指定工程名不指定驱动器名/路径名(空白)，将自动在缺省的驱动器/路径

中创建并保存工程。 
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7) 工程名 

指定一个工程名。 

 

以下说明可以用来指定驱动器路径、工程名或数据名的字符及字符数。 

 

· 字符数 

用来指定工程路径及工程名(可以使用八个或更多字符)的所有字符数为单

字节文字（英文等）150 个或双字节文字（中文等）75 个。 

<例子> 

C:\SW3D5GPPW\ABCDEFGHIJKLMNOPQRSTUVWXYZ 

 

· 在 A，QnA 和 FX 系列中不能使用的字符 

/、\、>、<、* 、?、“ ‘’、|、:、; (: 和 \ 只能用于驱动器) 

切记不要在工程名最后使用句号(。)或空格( )。(如果在工程名右边有空

格，空格会被自动删除。) 

 

8) 标题 

工程标题最多可以是 32 个字符。 

 

9)  OK  按钮 

单击此按钮新建工程。 
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3.2 向已创建工程中追加 FB 定义 

[设置目的] 

为已创建的工程追加新的 FB 定义。 

用由一个 FB 程序和标识？组成的 FB 定义来设置程序中使用的标识(变量)。 

 

[操作步骤] 

·选择[Project] → [Edit Data] → [New]. 

·在工程数据列表中单击鼠标右键然后选择[New]。 

 

[对话框] 
 

 
 

[说明] 

1) 数据类型 

选择功能块。 

2) 程序类型 

创建 FB 时，选择梯形图程序或 ST 程序。 

3) 数据名 

设置新追加的数据名(FB 定义名)。 

在八个单字节字符或 4 个双字节字符以内设置数据名。 

 

· 可以使用的字符 

字母数字字符、_、^、$、、~ (代字号)、!、#、%、&、( )、-、{ }、

@、 

* (省略符号)、'(单引号)。 

· 不可以使用的字符 

使用 " = | : ; 、\ [ ] + * ? <> . / 中任何一个字符都会引起错误。 

 

如果工程中已经创建了其它 FB 定义，在新建对话框的数据名区域就会显示该 FB

定义的名字。 
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4) 标题 

为工程设置标题，标题最多为 32 个字符。 

 

5)  OK  按钮 

单击此按钮新建 FB 定义。 

 

要点  

(1) 在一个工程中创建 FB 定义的数量没有限制。(FB 定义的数量取决于工程存储目

标的容量。 

(2) 如果在一个工程中创建了多个 FB 定义，建议创建一个标题以便可以轻松搜索目

标 FB 定义。 
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3.3 创建 FB 定义程序 

[设置目的] 

使用标识(变量)创建 FB 定义程序。 

 

[操作步骤] 

在<<FB>>标签中双击功能块，然后双击 FB 定义或分别点击各个程序。 

 

 

[窗口]梯形图程序 
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[窗口]ST 程序 
 

 
 

[创建程序] 

(1) 要创建一个 FB 定义程序，与在 FB 定义窗口创建标准的顺控程序执行同样的操

作。 

以下面的规格创建程序。 
 

项目 说明 

程序容量 最大:2048 步(对于 ST 程序: FB 定义转换后，最大 2048 步) 

编程语言 梯形图、列表、ST 

支持模式 写入、读取 

标签数 最大:500 个 

 

(2) 使用标识(变量)创建程序。 

被使用的标签详细说明了下列四种不同的功能。使用 FB 变量定义标签。 

(请参考 3.4 节) 
 

类型 说明 

输入变量 对 FB 的输入的变量。 

最多 24 个。包括输入输出变量，至少 1 个。 

输出变量 从 FB 输出的变量。 

最多 24 个。包括输入输出变量，至少 1 个。 

输入输出变量 既有输入功能又有输出功能的变量。 

最多 24 个。 

内部变量 只在 FB 内部使用的变量。 

{500-(输入变量+输出变量+输入输出变量)}个。 
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在 16 个字符内创建标识。 

预留字及实际软元件名都不能用作标识。 

如果使用了预留字或实际软元件名作标识，会出现“预留字已被使用。”或“软

元件名已被使用。”错误信息，应该重新设置为其它标识名。请参阅附录 1查看

不能使用的字符串。 
 

备注 

尽管 FB 定义允许使用实际软元件(如:X100， Y110)创建程序，但是很难在一个顺控

程序中使用多条相同的 FB 定义。(不推荐这种做法，因为可能会引起重叠线圈。) 
 

以下面的程序实例来说明怎样使用标识。 

(a) 使用标识的 FB 定义程序 
 

<梯形图程序> 
 

 

 

1) 变量 IN1 和 IN2 的 ON/OFF状态以外部 ON/OFF信息作为条件。 

2) 变量 PLUS1 把外部数字信息输入至 FB 内部。 

3) 变量 PLUS2 把 FB 内部(数字信息)的计算结果输出至外部。 

4) 变量 OUT1 和 OUT2利用 FB 内部(ON/OFF信息)的计算结果控制外部输出。  

5) 变量 RA1 和 RA2 只用于 FB 内部。 
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<ST 程序> 
 

 
 

1) 变量 IN1 的 ON/OFF状态以外部 ON/OFF信息为条件，并将 FB 内部(ON/OFF信

息)的计算结果输出至外部。 

2) 变量 IN2 的 ON/OFF状态以外部 ON/OFF信息为条件。 

3) 变量 PLUS1 把外部数字信息输入至 FB 内部。 

4) 变量 PLUS2 把 FB 内部(数字信息)的计算结果输出至外部。 

5) 变量 OUT1 和 OUT2利用 FB 内部(ON/OFF信息)的计算结果控制外部输出。  

6) 变量 RA1 和 RA2 只能用于 FB 内部。 

 

(b) 顺控程序的操作实例，顺控程序使用了已创建的 FB 定义。 
 

<梯形图程序> 
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<ST 程序> 

 
 

(3) 其它 FB 不能用于 FB 定义程序。 

 

(4) 关于 FB 定义，切记不要创建可以跳到 FB 定义外部的程序。(如:CALL 指令跳转到

子程序) 

 

(5) 在 FB 定义窗口创建程序，以 0 步开始。 

FB 定义程序没有 END 指令。 

END 指令入口会显示错误。 

 

(6) 程序创建完成后，转换程序。 

下列三种操作都可以完成程序转换。 

(a)  F4  键 

(b) [Convert]  [Convert/Compile] 

(c) 在 FB 定义窗口上点右键然后选择[Convert/Compile]。 

(只适用于梯形图) 

 

(7) 在 FB 定义窗口上，窗口标题上标有“*”时表示程序未编译。 
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(8) 用标识创建 FB 定义程序时请注意下列各项: 

(a) 变址修饰不能与标识一起使用。 

变址修饰的标识被认为是新标识。 

(例子) 

当输入具有变址登录“Z1”的“PLUS1Z1”去修饰标识“PLUS1”时，FB 定义

程序被认为是标识"PLUS1Z1"。 

(动作) 

使用实际软元件作为要被变址修饰的软元件。 
 

(b) 因为数字软元件最多可存储两个字数据，若指令超过三个字则不能从外部输

入。 

(例子) 

关于写指令“TO”写入数据至智能功能模块时，由输入变量最多可以输入两

个字。 

(动作) 

为了从外部输入三个或更多字，使用实际软元件作为存储输入值的软元件或

通过创建必要次数的输入指令。 
 

(c) 因为数字软元件最多可存储两个字数据，如果指令结果有三个或以上字则结

果不能输出。 

(例子) 

对于 BIN32-位乘法“D*”，用来存储乘法结果的软元件需要四个字。 

(动作) 

要输出三个或以上字数据，应使用实际软元件作为存储结果的软元件。 
 

备注 

本手册没有详细叙述创建程序的操作。 

有关创建程序操作的细节，请参阅相关手册中提供的 GX Developer版本 8 操作手

册。 
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3.4 创建 FB 变量 

[设置目的] 

设定用于 FB 定义程序中的变量类型、常数值、软元件类型以及标识的注释(变量)。 

FB 变量必须与 FB 定义程序成对出现。 

 

[操作步骤] 

在<<FB>>标签中双击功能块，然后双击“Header”。 
 

 

 

[窗口] 
 

 
[说明] 

1) 输入/输出 

选择标识类型。有四种不同的类型供选择。 

·VAR_INPUT : 输入至 FB外部的变量 

·VAR_OUTPUT : 输出至 FB外部的变量  

·VAR_IN_OUT : 既有输入功能又有输出功能的变量 

·“空白” : 用于 FB 内部的变量 

2) 标签 

设置在 FB 定义程序中使用的标识(变量)。 

3) 常数 

为变量类型为“空白”的标识设定常数时，设置一个常数值。 

为便于识别十进制数、十六进制数、实数和字符串常数，分别用 K、H、E 和

“”表示。 
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4) 软元件类型 

·对于输入变量、输出变量和 I/O 变量，从后面数据类型中任选一个:位、

字、双字、实数和字符串。 

软元件内容如下所示。 

1) BOOL : 用 ON/OFF 表示数据。 

2) INT : 用 16位表示数据。 

3) DINT : 用 32位表示数据。 

4) REAL : 用 32位表示浮点数据。 

5) STRING : 用 JIS8 代码表示字符串数据。 

·有关内部变量，从后面数据类型中任选一个:ARRAY、TIMER、COUNTER、

STORED TIMER 和 POINTER。 

6) 数组: 当处理多种数据(如 BMOV 或 FMOV 指令)时，应指明要被处理的数

据数。 

选择 STRING 或 ARRAY，显示相应的下面对话框中当中的一个。 

字母数 

: 输入范围为 1 至 50 个字符。 

因子数 

: 输入范围为 1 至 255。 

   
5) 注释 

设定一个 64 个字符以内的注释。 

当 FB 中的顺控程序带有标签显示

时，在标签下面设定此区域的注

释。 

关于 ST 程序，选择[View] → 

[Label information]然后把光标

放在 ST 程序上显示以工具提示格

式出现的注释。 

  

6) 编辑操作 

 Insert  按钮 

用来在当前单元位置插入一个空白行。 

若想批量插入多个行，应选择你想插入的行单元。空白行会插到所选单元的范

围内。 

 Add  按钮 

用来在当前单元位置的行下面添加一个空白行。 

若想批量添加多个行，应选择你想添加的行单元。以所选范围单元中第一个下

面的行开始添加行。 

 Delete  按钮 

用来删除所选单元的范围。 



 

 

 

3 - 15       3 - 15 

MELSOFT 
3 使用 FB 创建顺控程序 

 

7)  Resister  按钮 

单击  Resister  按钮登录 FB 变量。 

若标识、常数值和软元件类型中任意一

个被错误设置，就会出现右边的对话框

提示变量不能登录。 

选择错误内容然后单击跳跃按钮显示错

误位置。 

 
 

要点  

在 FB 变量设置窗口，以标签顺序、常数顺序及软元件类型顺序排列设置项目。排

序先后如下所示: 

1.符号 

2.字母表(大写字母) 

3.字母表(小写字母) 

 

FB 定义自动地把软元件分配到程序中所用的标

识上。创建顺控程序时，应避免自动分配软元

件。 

与本地软元件一样，被自动分配的软元件要根

据自动分配的软元件设置而设定。被自动分配

的软元件默认以下软元件范围。 

1) 字软元件 : D6144 至 D12287 

2) 位软元件 : M4096 至 M8191 

3) 定时器 : T64 至 T2047 

4) 计数器 : C512 至 C1023 

 
若想改变软元件范围，选择[Edit] → [Auto device setting]显示自动软元

件设置对话框，然后改变软元件范围。 

 

备注 

有关在自动软元件设置对话框上执行的操作细节，请参阅 GX Developer 版本 8 操

作手册中的“标识程序”。 
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3.5 转换 FB 定义(转换(编译)) 

[设置目的] 

转换已创建的 FB 定义，使其能用于顺控程序。 

 

[操作步骤] 

选择[Convert] → [Convert/Compile]。 

 

[操作项目] 

(1) 转换(编译)正常完成后，会出现下面的对话框。 

 

单击  YES  在软元件注释内写入标识注释。 

 

(2) 执行转换(编译)期间，进行错误检测时会出现下面的对话框。 

 

选择错误内容并单击跳转按钮显示错误位置。 

 

(3) 检测出错误后，修正错误位置然后再次执行转换(编译)。 

在顺控程序中，只能使用已经完成转换(编译)的 FB 定义。 
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(4) 当已经创建了多个 FB 定义时，可以通过执行一次编译操作编译所有 FB 定义。 

执行编译期间进行错误检测时会出现如(2)中所示的对话框。 

单击 All programs  显示可以允许确认所有程序中错误数量的对话框。 

 

 

(显示例子) 

[ADD_1(P)].... FB定义 ADD_1中的错误数量 

[FB:ADD_3(L)]. FB定义 ADD_3中的错误数量 

[FB:ADD_2(L)]. FB定义 ADD_2中的错误数量 

[ADD_2(P)].... FB定义 ADD_2中的错误数量 

[ADD_3(P)].... FB定义 ADD_3中的错误数量 

 

选择程序名称并单击  Detail  显示所选项目的详细对话

框。 
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3.6 将已转换的 FB 粘贴至顺控程序(FB 利用) 

 

3.6.1 将 FB 定义粘贴至顺控程序 

 

[设置目的] 

把 FB 定义粘贴至正在创建的顺控程序上，这样可以使用 FB。 

 

[设置步骤] 

执行下列三种不同操作中的任何一种都可以使用 FB。 

(1) 在 FB 标签上使用鼠标拖放的方法 

(2) 使用功能块转换对话框的方法  

(3) 使用指令对话框的方法 

 

下面解释说明了上术操作的步骤。 

 

(1) 在 FB 标签上使用鼠标拖放的方法 

(a) 显示将粘贴有 FB 定义的顺控程序。 

从工程标签上选择目标顺控程序名称显示顺控程序。 

设置成梯形图(写入)模式。 
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(b) 进行从工程标签至 FB 标签的切换，然后从 FB 标签将 FB 定义拖放至顺控

程序上。 

 

 

(c) 在顺控程序上 FB出现在光标指定的地方(放位置)。 

 

 

要点  

(1) FB定义要被粘贴到的位置由光标指定的地方决定。 

(a) 当粘贴位置是一个梯形图块而不是FB时 

(在插入/覆盖模式中) 插入至粘贴位置的梯形图块上面的行中。 

(b)  当粘贴位置是一个包含FB的梯形图块时 

(在插入模式中) 插入至粘贴位置的梯形图块上面的行中。 

(在覆盖模式中) 改写粘贴位置的FB。 
 

(2)  对粘贴至顺控程序FB数目没有限制 
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(2) 使用功能块转换对话框的方法 

(a) 显示将要粘贴有 FB 定义的顺控程序。 

从工程标签中选择目标顺控程序名称显示顺控程序。 

设置梯形图(写入)模式。(执行如(1)-(a)中相同的操作。) 

 

(b) 选择[Project] → [Function Block] → [Diversion]显示转换功能块对

话框。 
 

 

双击并利用来自于转换功能块对话框的

FB 定义名。 

或者，单击后选择要使用的 FB 定义名，

然后单击  OK  按钮。 

 

(c) 在顺控程序中 FB出现在光标指定的地方(放位置)。(与(1)-(c)同) 

 

(3) 输入指令列表对话框 

(a) 显示将要粘贴有 FB 定义的顺控程序。 

选择来自于工程标签中目标顺控程序名称显示顺控程序。 

设置梯形图(写入)模式。(与(1)-(a)中操作相同) 

 

(b) 在顺控程序中，在键盘上输入“FB，'FB 定义名'”。此操作显示了输入符

号窗口然后将其写入到软元件指令输入区。例子:FB.ADD_1 

 

 

(c) 在顺控程序上单击  OK  按钮显示光标指定地方的 FB。 

(与(1)-(c)同) 

 

参考 

有关 ST 程序中的 FB转换，请参阅“QCPU(Q 模式)编程手册(结构文本)”。 
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3.6.2 变更已粘贴的 FB 名(FB 名)(变更 FB 名) 

本操作具有可选性，应按需要执行本操作。 

 

[设置目的] 

变更已粘贴 FB 的 FB 名。 

要点  

粘贴至顺控程序上的 FB 名“(FB1)”显示在 FB 定义名后右边的括号“()”内。 

 

若多块相同的 FB 或一些其它 FB 粘贴至顺控程序上，这些 FB 会自动地分配到在序

号上依次顺延的指定的 FB 名，如“FB1”、“FB2”、“FB3”。 

 

执行本操作便于使将多个 FB 粘贴至顺控程序上更容易确认。 

 

[操作步骤] 

选择[Project] → [Function Block] → [Rename FB]。 

 

[设置步骤] 

(1) 在重命名功能块对话框中键入旧数据名和新数据名。 

可以从列表框中选择旧数据名。 

若重新选择名称将要变更的 FB，在变更前的数据名区中为缺省 FB 名。 
 

 
可以在 16 个字符内输入 FB 名。 

预留字及实际软元件名不能用作 FB 名。 

若使用了预留字或实际软元件，就会出现下面的出错信息。因此，要设置其它

标识名。请参阅附录查询不能使用的字符串。 
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(2) 单击  OK  按钮显示 FB 中的新 FB 名。 

 

当已经变更了 FB 名时，其变更如下所示。 

 

 
 

要点  

写入模式下可以执行 FB 名的变更。 

读取模式下不能执行 FB 名的变更。 
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3.6.3 变更 FB 定义的模块开始 I/O 地址 

[设置目的] 

变更用于 FB 定义中的一批模块开始 I/O地址(Un，Un/Gm)、I/O软元件(X，Y，DX，

DY)。 

 

[操作步骤] 
 

 

1. 在工程数据列表中选择 FB 标签。 

 

2. 双击并选择将要变更的使用模块开始 I/O

地址的 FB 定义中的程序。 

(将会出现 FB 定义(程序)) 

 

3. 选择[Project] → [Function Block] → 

[FBchange module address]。 

 

4. 为设定于 FB 定义中的最低模块开始 I/O地址指定新的模块开始 I/O地址。 

 

将要变更的一批模块开始 I/O地址如下所示: 

 

FB 定义(Body)变更前 
 

 
 

FB 定义(程序)变更后 
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要点  

· 活动 FB 定义画面上的模块开始 I/O地址和 I/O软元件将会被变更。 

可以通过检查标题栏或检查 GX Developer 的模块开始 I/O 地址设置画面确认活

动 FB 定义画面。 
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3.7 创建顺控程序 

 

3.7.1 编辑顺控程序 

[设置目的] 

为粘贴到顺控程序上的 FB 创建输入梯形图区和输出梯形图区。 

 
 

向已经创建了输入和输出梯形图区的 FB添加其它梯形图，用来完善顺控程序。 
 

 
 

[创建程序] 

(1) 粘贴 FB 后，可以通过执行与创建标准梯形图格式顺控程序相同的操作创建顺控

程序。 

备注 

本手册没有详细给出创建程序的注意事项。 

相关内容，请参阅相关手册中所给的 GX Developer版本 8 操作手册。 

 

(2) 在已粘贴的 FB 中，输入变量的标识显示在左边，输出变量的标识显示在右边。

输入侧标识以“‘软元件类型’，‘标识名称’”显示，输出侧标识以“‘标

识名称’，‘软元件类型’”显示。 

软元件类型通过下面的字母表示。 

(a) BOOL : B 

(b) INT : W 

(c) DINT : D 

(d) REAL : E 

(e) STRING : S   
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(3) 每个标识都与输入或输出梯形图区相连。 

可以连接到输入或输出梯形图区的梯形图取决于已连接标识的软元件类型。 

(a) 当软元件类型为 BOOL 时 

1) 在输入梯形图区，创建成为输入变量条件的指令，如:触点、结合及比

较运算等操作指令。 

2) 在输出梯形图区，创建提供输出的指令如:输出及运算操作指令。输出

变量是输出指令的一个条件。 
 

(b) 当软元件类型为 INT/DINT/REAL/STRING 时 

1) 将一个字软元件(包含一个指定位的位软元件或常数)连接到输入梯形

图区。字软元件的信息存储到输入变量中。 

2) 将一个字软元件(包含一个指定位的位软元件)连接到输出梯形图区。

输出变量的信息存储到字软元件中。 
 

要创建将要连接字软元件的梯形图，单击  按钮或按  F8  键显示输入符

号窗口，然后在软元件指令输入区键入软元件。(当软元件类型是 INT/REAL/ 

STRING 时，占用了与已输入软元件一起开始的连续软元件。) 

 
下面是已经连接到 FB上的输入与输出梯形图区的举例。 

 

 
 

输入和输出梯形图区的规格显示如下。 

(a) 显示输入梯形图区的宽度:等于四个触点的宽度。 

(b) 显示输出梯形图区的宽度:等于三个触点+一个线圈的宽度。 

不能在输入与输出梯形图区进行反向连接。因此，如果以上述显示的宽度不能创

建梯形图，请使用一个内部继电器或类似设备在其它梯形图块中继续创建梯形

图。 
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(4) 如果 FB 的输入变量/输出变量不能在输入梯形图区/输出梯形图区中连接，则不

会导致出错 

转换顺控程序后，没有连接的输入变量/输出变量的显示形式是:通过来自于输

入梯形图区左边总线或输出梯形图区右边总线的水平线，将其连接到 FB。 

在此种情况下，输入变量是不确定的，输出变量未输出到外部。 
 

 
 

(5) 按如下说明编辑包含 FB 的顺控程序。 

(a) 在包含 FB 的梯形图块中可以进行剪切/复制。 

只有在输入梯形图区、FB 和输出梯形图区中的任何梯形图区中不能进行剪

切/复制。 

因为复制的 FB 被认为是不同于复制源的 FB，FB 名称会自动变成从

“FB1”至“FB2”至“FB3”。 

(b) 可以在包含 FB 的梯形图块中插入行。 

(c) 可以在包含 FB 的梯形图块中删除行。 

(d) 不能在梯形图恢复的地方插入列。 

(e) 可以在输入梯形图区/输出梯形图区中删除列。 

(f) 不能在包含 FB 的梯形图块中登录/应用宏。 
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3.7.2 确认已粘贴 FB 的数据 

[设置目的] 

在已粘贴的状态下，隐藏被粘贴到顺控程序上的 FB 数据以便简化显示顺控程序。 

创建顺控程序期间，想确认 FB 数据时执行此操作。 

 

[操作步骤] 

(1) 双击相应的 FB。 

 
 

备注 

有关 ST 程序的操作，请参阅“GX Developer版本 8 操作手册(结构文本)”。 

 

(2) 出现 FB窗口。 

 

 

如果已经显示了 FB 定义窗口或 FB 变量设置窗口，则会出现下面的对话框。 
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单击  Yes  按钮关闭 FB 定义窗口或 FB 变量设置窗口，然后显示 FB窗口。 

 

要点  

FB窗口用来读取、监视和检测 FB 程序。不能在此窗口修正程序。 

修正 FB 程序时，打开 FB 定义窗口。 

FB 定义窗口打开时 FB窗口关闭。 
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3.7.3 查找/替换顺控程序(查找/替换) 

[设置目的] 

在已创建顺控程序中查找或替换软元件、指令或类似项时，执行此操作。 
 

[操作步骤] 

选择[Find/Replace] → [Find device]，[Find instruction]，[Find step no.], 

 [Find character string]，[Find contact or coil]， 

 [Replace device]，[Replace instruction]， 

 [Change open/close contact]， 

 [Replace character string], 

 [Change module start address]， 

 [Replace statement/note type]， 

 [Cross reference list]，[List of used device]。 

备注 

本手册没有详细说明查找/替换操作。 

相关细节，请参阅相关手册中所给的 GX Developer版本 8 操作手册。 
 

[项目说明] 

(1) 如下所示，目标窗口决定了查找/替换在执行范围上有所不同。 
 

目标窗口 执行范围 

顺控程序窗口 正在显示的顺控程序是查找/替换的目标。 

但是，已粘贴的 FB 不包含在目标中。*1 

FB 定义窗口 只有正在显示的 FB 定义程序是查找/替换的目标。 

FB 窗口 只有正在显示的 FB 定义程序是查找的目标。 
 

(2) 查找/替换可用于如下所示的窗口。 
 

查找/替换项目 顺控程序窗口 FB 定义窗口 FB窗口 

查找软元件 

查找指令 

查找步号 

查找字符串 

查找触点或线圈 

可以执行 可以执行 可以执行 

替换软元件 

替换指令 

变更打开/关闭触点 

替换字符串 

变更模块开始地址 

替换声明/注解类型 

可以执行 可以执行 不能执行 

交叉参考列表 

已使用的软元件列表 
可以执行 可以执行 可以执行 

*1: 只有查找字符串可以查找粘贴到顺控程序上的 FB 的 FB 定义名或 FB 名。 
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要点  

当查找粘贴到顺控程序上的 FB 时，在查找字符串中，可以在目标 FB 中指定 FB 定

义名或 FB 名便于查找目标 FB。 

 

(1) 键入 FB 定义名或 FB 名后，单击  Find Next  按钮。 
 

 
 

(2) 将光标放在 FB区的左上角。 
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3.7.4 创建/显示注释、声明或注解(创建句子) 

[设置目的] 

为了提高程序的可读性，在顺控程序中创建注释、声明或注解。 

通过设置显示格式可以显示创建的注释、声明或注解。 

 

[操作步骤] 

(1) 创建顺序 

选择[Edit] → [Documentation] → [Comment]、[Statement]或[Note] 

(2) 显示顺序 

选择[Edit] → [Comment]、[Statement]或[Note]。 

 

备注 

本手册没有详细说明创建注释、声明和注解的操作。 

相关细节，请参阅相关手册中所给的 GX Developer版本 8 操作手册。 

 

[说明] 

(1) 注释 

可以为软元件(该软元件位于包含 FB 的梯形图块的输入和输出梯形图区)创建注

释。 

 

(2) 声明 

只能在包含 FB 的梯形图块的输入梯形图区的第一个梯形图中创建声明。 

不能在输出梯形图区创建声明。 

 

(3) 注解 

只能在包含 FB 的梯形图块的输出梯形图区中创建注解。 

不能在输入梯形图区创建注解。 
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3.8 把顺控程序转换至在 PLC CPU 中可执行的程序(转换(编译)) 

[设置目的] 

粘贴 FB 的顺控程序如果不进行转换不能在 PLC CPU上执行，需进行转换(编译)操作

将其转换成可在 PLC CPU上执行的程序。 

 

[操作步骤] 

选择[Convert] → [Convert/Compile]，[Convert/Compile (All programs being 

edited)]或[Convert/Compile (All programs)]或[Convert/Compile (Online 

change)]。 

 

[说明] 

(1) 编译正常完成时将出现下面的对话框。 
 

 
 

检测出错误时会出现下面的对话框。 

 
 

如果错误发生在多个程序中，会出现“编译错误(所有程序)”。 

如果错误只发生在一个程序中，会出现“编译错误(细节)”。 
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(2) 如果没有转换(编译)完毕，顺控程序的窗口标题会标有“*”。 

 
 

(3) 转换(编译)后执行的程序不在 GX Developer 中显示。 
 

备注 

在已转换(编译)的顺控程序中，依据自动软元件设置把软元件分配给标识。 

自动软元件设置默认下列软元件范围: 

1) 字软元件 : D6144 至 D12287 

2) 位软元件 : M4096 至 M8191 

3) 计时器 : T64 至 T2047 

4) 计数器 : C512 至 C1023 

从末尾的数字(D12287、M8191、T2047、C1023)开始按顺序把软元件分配给标

识。 

 

下面是转换(编译)后执行的程序例子。 

(a) 顺控程序 

当 X0 打开并且 D400 的值超出 4000 时，该梯形图例子把 100 存储到 D400

中。 

 

 
(b) 转换(编译)后执行程序 

 

标识 分配的软元件 

in1 M8191 

in2 D12287 

out10 D12286 
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输入梯形图区中的触点 X1 及输入与输出梯形图区中的 D400 不能被 FB 定义程序中的标

识 in1、in2 和 out10直接替换。 

·触点 X1与软元件 M8191(分配给 in1)的线圈相连。 

·输入梯形图区中的软元件 D400总是传输据给软元件 D12287(分配给 in1)。 

·软元件 D12286(分配给 out11)总是传输据给输出梯形图区中的软元件 D400。 

 

在 PLC CPU启动时，因为可执行程序中软元件 D12286/D12287 的值不确定，如果输入

梯形图区中 D400小于 4000则输出梯形图区中的 D400 将变为一个不确定值。 

为避免此情况，连接相同的标识并设定变量类型为 I/O 变量。设定变量类型为 I/O 变

量把相同软元件连接至输入与输出梯形图区。 

下面是采取了以上补救措施的程序例子。 

 

(a) 顺控程序 
 

 
 

 

(b) 编译后执行的程序 
 

标识 分配的软元件 

in1 M8191 

in _ out 10 D12287 
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3.9 从 PLC CPU 读取顺控程序(读取 PLC) 

[设置目的] 

读取来自于 PLC CPU 的顺控程序。 

 

[操作步骤] 

选择[Online] → [Read from PLC]或单击  。 

备注 

本手册未详细说明关于读取于 PLC 的操作。 

关于读取于 PLC 的操作细节，请参阅相关手册中所给的 GX Developer版本 8 操

作手册。 

 

[设置步骤] 

(1) 在传输设置中设定访问目标。 

(2) 显示读取于 PLC 对话框的数据。 

(3) 选中将要读取于 PLC 的数据名的复选框。 

若想选择工程中的参数及所有程序，单击  Param+Prog  按钮。 

(4) 单击  Execute  按钮。 

 

要点  

当标识程序将要读取于 PLC 时，创建或读取了在标识设置中选择“使用标识”的工 

程后开始读取 PLC。 
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3.10 将顺控程序写入 PLC CPU 中(写入 PLC) 

[设置目的] 

将已转换的顺控程序写入 PLC CPU 中。 

 

[操作步骤] 

选择[Online] → [Write to PLC]或单击  。 

备注 

本手册未详细说明写入至 PLC 的操作。 

关于写入至 PLC 的操作细节，请参阅相关手册中列出的 GX Developer 版本 8 操

作手册。 

 

[设置步骤] 

(1) 在传输设置中设定访问目标。 

(2) 显示写入至 PLC 对话框。 

(3) 开启并选择将要写入至 PLC 的数据名的复选框。 

若想选择参数及工程的所有程序，单击  Param+Prog  按钮。 

(4) 单击  Execute  按钮。用框把 Execute 框上 

 

要点  

(1) 关于 Q 或 QnA 的综合声明，会与程序一起写入至 PLC CPU 中。 

外围声明未写入至 PLC CPU 中。在这种情况下，声明/注释合并选项具有把声 

明/注释与当执行读取于 PLC 时个人计算机中的声明/注释合并的功能。 

当程序未使用此功能读取于 PLC 时，保存没有声明/注释的程序时注意不要意 

外地覆盖掉旧程序。 

(2) 如果“标识程序(ST、FB、structure)”的复选按钮未选中就执行写入至 PLC 

操作，会出现下面的错误信息。当选择 Yes按钮时，只有执行程序被写入至

PLC 中且不能读取标识程序。 
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3.11 监视与测试顺控程序 

 

3.11.1 监视顺控程序 

[设置目的] 

监视已经写入至 PLC CPU 中的顺控程序来检查 PLC CPU 的操作状态。 

可以像监视触点和线圈一样来监视粘贴至顺控程序的 FB。 

也可以像监视顺控程序一样来监视 FB 中的程序。 

 

[操作步骤] 

· 监视时 

选择[Online] → [Monitor] → [Monitor mode]或单击  (  F3  )。 

 

· 停止监视时 

选择[Online] → [Monitor] → [Stop monitor]或单击  (  Alt+F3  )。 

 

· 重新监视时 

选择[Online] → [Monitor] → [Start monitor]或单击  (  F3  )。 

 

[窗口] 

通过下面的实例分析粘贴了 FB 的顺控程序，并监视 FB 中的程序。 

(1) 顺控程序显示在下面的监视窗口中。 
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顺控程序中包含 FB 的梯形图块显示于如下所述的监视画面中。 

(a) 关于输入变量(BOOL) 

1) 当条件为 ON 时，输入变量的标识高亮显示。 
 

 
 

2) 当条件为 OFF 时，输入变量的标识不高亮显示。 
 

 
 

(b) 关于输入变量(INT/DINT/REAL) 

显示了存储在标识的数字值。 
 

 
 

(c) 关于输出变量(BOOL) 

1) 当输出变量为 ON 时，标识高亮显示。 
 

 
 

2) 当输出变量为 OFF 时，标识不高亮显示。 
 

 
 

(b) 关于输出变量(INT/DINT/REAL) 

显示了存储在标识的数字值。 
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(2) 监视 FB 程序时，双击顺控程序中的 FB 来显示 FB窗口。然后，在显示的 FB窗

口上执行监视。 
 

 
 

如果已经显示了 FB 定义窗口或 FB 变量设置窗口，则会出现下面的对话框。 
 

 
 

单击  Yes  按钮关闭 FB 定义窗口或 FB 变量设置窗口，然后显示 FB窗口。 
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3.11.2 测试顺控程序(软元件测试) 

[设置目的] 

通过对 PLC CPU 中的位软元件强制转变 ON/OFF状态或改变字软元件的当前值来检查

已创建的顺控程序。 

粘贴至顺控程序上的 FB 可以象触点和线圈一样进行软元件测试。 

FB 中的程序也可以象顺控程序一样进行软元件测试。 

 

[操作步骤] 

选择[Online]  [Debug]  [Device test] 或单击  (  Alt  +  1  )。 

 

[对话框] 
 

 
 

[设置步骤] 

下面的例子解释了在粘贴至顺控程序的 FB上进行的软元件测试。 

(1) 选择 FB 目标标识进行软元件测试。 
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(2) 当选择[Device test]时，上步选择的软元件名(ADD_1.IN1)会自动输入在软元

件区域。 
 

 
 

(a) 当所选标识的软元件类型为位时，软元件区域输入的标识是位软元件。 

(b) 当软元件类型为 INT/DINT/REAL 时，软元件区域输入的标识是字软元件/

缓冲存储器。 

 

(3) 在所选标识上进行软元件测试。 
 

 
 

(4) 标识的软元件测试已完成。 

 

(5) 当对另一标识进行软元件测试时，直接把标识输入至软元件区域。 

在软元件区域键入“‘FB 名’、‘标识名’”。 

 

要点  

如果目标标识的软元件类型为位，按住  Shift  键并双击顺控程序中的 FB 标识强

制转换 ON/OFF状态。 

如果目标标识的软元件类型为 INT/DINT/REAL，则会出现软元件测试对话框。 
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3.12 修正 FB 

[设置目的] 

如果监视/测试顺控程序中的 FB 不能按预期运行，修正 FB 程序。 

要点  

(1) 如果执行了从 PLC 中读取操作既从 PLC CPU 中读取程序，顺控程序中的 FB则

不能显示。 

GX Developer显示已经编译完的顺控程序。 

因此，应小心存储还未编译完的程序，因为它需要修正 FB。 

(2) 在 FB 定义窗口修正 FB 程序。 

在 FB窗口不能修正程序。 

(3) 注意如果多个相同 FB 定义粘贴至顺控程序，对 FB 定义程序的修正将影响所有

FB。 

 

 

[设置步骤] 

(1) 在 FB 标签上双击并选择要修正的 FB 定义。 

 

(2) FB 定义窗口出现后，修正程序。 

如果已经显示了 FB窗口，则会出现下面的对话框。 
 

 
 

单击  Yes  按钮关闭 FB窗口，然后显示 FB 定义窗口或 FB 变量设置窗口。 

 

(3) 程序修正完成后，编译 FB 定义。 

如果未执行编译，修正不会影响已经粘贴至顺控程序中的 FB。 

 

(4) 编译粘贴 FB 定义的顺控程序，其中 FB 定义已修正过。 

如果未执行编译，对 FB 的修正不会影响顺控程序。 
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3.13 对顺控程序进行在线程序写入 

[设置目的] 

将已修正的顺控程序写入至处于 RUN状态的 PLC CPU 中。 

 

[操作步骤] 

选择[Convert] → [Convert/Compile(Online change)]或按  Shift  +  F4  。 

 

要点  

(1) 关于在线变更的其它注意事项，请参阅 GX Developer 操作手册。 

(2) 如果要进行在线变更的 FB 定义被用于多个程序中，则不能进行在线变更。会

出现下面的信息。 

 
 

(3) 如果要进行在线变更的程序的 FB 变量/FB 定义程序被改变，则不能进行在线

变更。会出现下面的信息。 
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4 利用已存在的 FB 创建顺控程序 

本章说明如何利用已经创建的 FB 创建顺控程序。 

4.1.1 节及 4.5 到 4.9 节中的操作步骤与 3.1 节及 3.5 到 3.9 节中的操作步骤相同。

有关说明，请参阅第三章相应章节。 

 

4.1 为 FB 创建工程 

 

4.1.1 创建新工程 

[设置目的] 

为 FB 创建新工程，需要设置 PLC 系列、PLC 类型和工程名。 

 

有关操作步骤的说明，请参阅 3.1 节。 

 

4.1.2 读取已存在的工程 

[设置目的] 

读取已保存的工程，将 FB 添加到该工程中。 

 

[操作步骤] 

选择[Project] → [Open project]或单击  (  Ctrl  +  O  )。 

 

[对话框] 
 

 
 

[说明] 

1) 工程名 

单击目标工程并设置工程名。 

2)  Open  按钮 

完成设置后，单击此按钮读取工程。 

 4 

 



 

 

 
 

4 - 2       4 - 2 

MELSOFT 
4 利用已存在的 FB 创建顺控程序 

 

4.2 使用已存在的 FB 定义(复制) 

利用已存在的 FB 定义有下面两种方法。 

(1) 在另一个工程上利用已存在的 FB 定义。(请参阅 4.2.1 节) 

(2) 在同一工程内利用已存在的 FB 定义。(请参阅 4.2.2 节) 

 

使用方法将在下面的章节进行说明。 

 

4.2.1 利用来自于其它工程的 FB 定义 

[设置目的] 

复制创建于另一工程上的 FB 定义来使用。 

 

[操作步骤] 

选择[Project] → [Copy]。 

 

[对话框] 
 

 
 

[说明] 

1) 驱动器/路径名，工程名 

单击  Browse  按钮，设置要复制的带有 FB 定义的工程。 

2) PLC 类型 

显示复制源工程的 PLC 类型。 

3) 复制源 FB 定义 

选择要复制的 FB 定义。 

 

 

 

 

 

 

 

4  
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4)  Execute  按钮 

单击此按钮执行复制。 

 

 当从另一个工程复制程序时，会显示下面的对话框。 

 

 
 

a) “删除所有先前变量后全部复制” 

被选中的复制源的全局标识变量设置将改写目标程序的变量设置。 

b) “覆盖先前变量并添加新变量” 

如果相同的全局标识存在于复制源和复制目标中，复制源中的全局标识变量将

改写目标程序的全局变量。 

非重复全局标识添加到目标程序中的全局变量中。 

c) “保留先前变量并添加新变量” 

如果相同的全局标识变量存在于复制目标和复制源中，复制源中的全局标识变

量不能改写目标程序的全局变量。 

非重复全局标识变量添加到目标程序中的全局变量中。 

 

[设置顺序] 

(1) 通过单击复制对话框上的  Execute  按钮，在工程中创建与复制源同名的 FB

定义。 

 

(2) 如果与复制源中具有相同名称的 FB 定义已经存在于复制目标中，会出现下面的

对话框表示复制已经停止。 

 

 
 

要继续执行复制，把复制目标中的 FB 定义名改为为其它名并再次执行复制。 

变更了 FB 定义名同样也会改变粘贴到顺序程序上的 FB 定义名。 

关于变更 FB 定义名，请参阅 4.3 节。 
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4.2.2 在同一工程内利用已存在的 FB 定义。 

[设置目的] 

复制已经创建于同一工程中的 FB 定义来使用。 

 

[操作步骤] 

·在<<Function Block>>标签上单击鼠标右键并选择 → [Copy]。 

·选择[Project] → [Edit Data] → [Copy]。 

·在<<Project>>标签上单击鼠标右键并选择 → [Copy]。 

 

[对话框] 

 
 

[说明] 

1) 数据类型 

选择功能块。 

当选择了复制源中的 FB 定义并打开复制对话框时，数据类型缺省为功能块。 

2) 复制源数据名 

想复制时请设定数据名(FB 定义名)。 

当选择了复制源中的 FB 定义并打开复制对话框时，数据名从一开始已经被设定

了。 

或者，当列表框显示了已创建的 FB 定义名时，可从该表上选择目标 FB 定义名。 
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3) 复制目标数据名 

设置复制目标中的数据名(FB 定义名)。 

列表框显示了已经创建的 FB 定义名，可以通过在该列表中选择 FB 定义名设置数

据名并对该名进行部分修正。在八个字符内设置数据名。 

 

· 可使用的字符 

文字数字字符、_、^、$、、~ (代字号)、!、#、%、&、(  )、-、{  }、

@、 

* (省略符号)、' (单引号) 

· 不能使用的字符 

使用 " = | : ; ， \ [  ] + * ? <> . /中任意一个都会导致错误。 

 

4) 标题 

为工程设置标题，不超过 32 个字符。 

 

5)  OK  按钮 

设置完成时单击此按钮。 

 

[设置顺序] 

(1) 单击复制对话框中的  OK  按钮显示下面的对话框。 
 

 
 

单击  Yes  按钮开始复制。 

 

(2) 如果复制目标中的 FB 定义名已经存在，会出现下面的对话框显示复制已经停

止。 
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4.3 更改 FB 定义名称 

[设置目的] 

为从其它工程中复制来的 FB 定义更改名称并为其设置一个新名称。 

 

[操作步骤] 

·在<<Function Block>>标签上点鼠标右键后选择 → [Rename]。 

·选择[Project] → [Edit Data] → [Rename]。 

·在<<Project>>标签上点鼠标右键后选择 → [Rename]。 

 

[对话框] 
 

 
 

[说明] 

1) 数据类型 

选择功能块。 

当选择了目标 FB 定义并打开了重命名对话框时，数据类型缺省为功能块。 

2) 变更前的数据名 

设置想要变更的数据名(FB 定义名)。 

当选择了目标 FB 定义并打开重命名对话框时，使用缺省的数据名。 

或者，从下拉列表框中选择已创建的 FB 定义名作为目标 FB 定义名。 
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3) 更改后的数据名 

设置新数据名(FB 定义名)。 

列表框显示了已创建的 FB 定义名，可以通过从该表中选择 FB 定义名来设置数据

名并对该名进行部分修正。设置数据名(不超过八个字符)。 

 

· 可使用的字符 

数字字符串、_、^、$、、~ (代字号)、!、#、%、&、(  )、-、{  }、@、 

* (省略符号)、' (单引号) 

· 不能使用的字符 

使用 " = | : ; 、\ [  ] + * ? <> . /中任意一个都会导致错误。 

 

4) 标题 

为工程设置标题(不超过 32 个字符)。 

 

5)  OK  按钮 

设置完成时单击此按钮。 
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4.4 修正 FB 定义中的程序或 FB 变量 

[设置目的] 

修正已使用的 FB 定义使其成为能够满足要求的程序。 

 

[设置顺序] 

(1) 双击使用的 FB，显示出 FB 定义窗口或 FB 变量设置窗口。 
 

 
 

(2) 修正 FB 定义窗口中的程序。 
 

 
 

(3) 修正完成后，添加并/或删除标识，编辑 FB 变量设置窗口中的标识。 
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4.5 转换 FB 定义(转换(编译)) 

[设置目的] 

转换已修正的 FB 定义使其能够用于顺控程序。 

 

关于操作步骤的说明请参阅 3.5 节。 

 

4.6 把已转换的 FB 粘贴至顺控程序(使用 FB) 

[设置目的] 

将 FB 粘贴至顺控程序上以便使用功能块。 

 

关于操作步骤的说明请参阅 3.6节。 

 

4.7 创建顺控程序 

[设置目的] 

为粘贴至顺控程序的 FB 创建一个输入梯形图区和一个输出梯形图区来完成顺控程

序。 

 

关于操作步骤的说明请参阅 3.7节。 

 

4.8 将顺控程序转换成在 PLC CPU 中可执行的程序(转换(编译)) 

[设置目的] 

粘贴有 FB 的顺控程序需经转换才可在 PLC CPU执行。 

 

关于操作步骤的说明请参阅 3.8节。 

 

4.9 将已转换的顺控程序写入至 PLC CPU 中(写入 PLC) 

[设置目的] 

将已转换的顺控程序写入至 PLC CPU中。 

 

关于操作步骤的说明请参阅 3.10节。 
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备忘录 
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5 从工程中删除多余的 FB 定义 

[设置目的] 

删除不再使用的 FB 定义。 

 

[操作步骤] 

·在<<FB>>标签上单击鼠标右键选择→ [Delete]。 

·选择 [Project] → [Edit Data] → [Delete]。 

·在<<Project>>标签上单击鼠标右键并选择→ [Delete]。 

 

[对话框] 
 

 
 

[说明] 

1) 数据类型 

选择功能块。 

当选择了 FB 并打开了删除对话框时，数据类型的缺省设置为功能块。 
 

2) 删除数据名 

设置将被删除数据的名称(FB 定义名)。 

当选择了 FB 并打开了删除对话框时，数据名为缺省设置。 

或者，在下拉列表框中选择需要删除的 FB 定义名。 
 

3)  OK  按钮 

设置完成后单击此按钮。 

 

[设置步骤] 

(1) 设置目标 FB 定义名并单击 OK 按钮显示下面的信息。 

 
 

(2) 单击  Yes  按钮删除 FB 定义。 

 5 
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要点  

(1) 删除 FB 定义时同时也删除了包括从顺控程序中已删除的 FB 定义(FB)的梯形图

块。 

执行删除之前，建议通过进行字符串搜索确认将要被删除的 FB 定义未正在顺

控程序中使用。(请参阅 3.7.3 节) 

 

(2) 删除 FB 定义时，如果包含要被删除的 FB 定义(FB)的顺控程序还未转换完，会

出现以下信息表示已停止了转换。 
 

 
执行删除操作之前，应先转换顺控程序或从顺控程序中删除包含 FB 的梯形图

块。 
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6 合并多个程序 

 

6.1 合并多个顺控程序 

[设置目的] 

当包含几个 FB 的多个顺控程序存在时，合并多个顺控程序。 

 

[设置步骤] 

通过执行[Tools]菜单中的[Merge data]操作并不能合并多个顺控程序。 

因此，必须通过在同一个工程中的顺控程序之间执行复制和粘贴操作将其合并。 

以下面的两个程序为例说明操作步骤。 

 

 
 

 
 

(1) 在源顺控程序中选择并复制步 0 至必要步的区域。 
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(2) 将复制的顺控程序粘贴至复制目标顺控程序要插入的步中。 

 

(3) 转换并保存顺控程序。 
 

要点  

不能在一个工程的顺控程序和另一个工程的顺控程序之间执行复制和粘贴操作。 

在这种情况下，执行下面的操作。 

(1) 选择[Project] → [Copy]来复制顺控程序及另一工程的 FB 定义。 

此时，如果复制源工程的 PLC 类型与复制目标工程的 PLC 类型不同，则不能执

行复制操作。 

在这种情况下，将复制源工程的 PLC 类型改成与复制目标工程的 PLC 类型相

同，并将其作为另一工程进行保存。 

(2) 在同一工程的顺控程序之间执行复制和粘贴操作。 

 

 

6.2 合并多个注释(数据合并) 

[设置目的] 

合并多个顺控程序中的注释。 

 

[操作步骤] 

选择[Tools] → [Merge data]。 

 

备注 

关于操作细节，请参阅 GX Developer 版本 8 操作手册中的“合并数据”。 

 

要点  

·在个人计算机中未保存的注释不能合并。 

·合并数据不能合并包含几个 FB 的多个顺控程序。 
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7 - 1       7 - 1 

MELSOFT 
7 校验工程 

7 校验工程 

[设置目的] 

校验相同 PLC 类型工程间的数据。 

 

[操作步骤] 

选择[Project] → [Verify]。 

 

备注 

关于操作细节，请参阅 GX Developer 版本 7 操作手册中的“在工程中校验数据”。 

 

执行工程校验显示以下项目的校验结果。 

(1) 参数 

(2) 标签程序 

(3) 当前程序 

 

下面是校验结果的显示例子。 

(a) 校验结果:当结果 OK 时 
 

 
(b) 校验结果:当结果不正确时 
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要点  

(1) 校验数据如下: 

·参数 

·已粘贴有 FB 的顺控程序 

·通过编译上述顺控程序获得的当前程序(程序写入至 PLC CPU 中)未校验 

FB 定义(程序本体，FB 变量)。 

 

(2) 如果校验了尚未编译的顺控程序，则会出现下面的信息显示校验已经被停止。 
 

 
 

(3) 如下所示，可以为校验源和校验目标选择多个数据。对相同名称的数据进行校

验。 
 

  
通过选中复选框选择数据名。 
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8 打印 

本章说明了关于打印包括 FB 的顺控程序及打印 FB 定义的操作方法。 

关于其它打印方法，请参阅 GX Developer 版本 7 相关手册中所给的操作手册。 

 

8.1 打印包括 FB 的顺控程序 

 

[设置目的] 

打印包括 FB 的顺控程序。 

 

[操作步骤] 

选择[Project] → [Print]或单击  (  Ctrl  +  P  )。 

 

[对话框] 

(1) 梯形图程序 
 

 
 

[说明] 

1) <<Ladder>>标签 

单击此标签切换至打印细节设置画面。 

2)  Print  按钮 

单击此按钮打印顺控程序。 
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[设置步骤] 

(1) 为打印设置好必需的信息后，单击[Print]按钮开始打印。 

 

(打印例子) 梯形图程序 
 

 
 

备注 

当用 FB 创建程序时下列项目不能打印。 

·MELSAP2、3 

·MELSAP-L 

·列表打印 
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(2) ST 程序 
 

 
[说明] 

1) <<ST>>标签 

单击此标签切换至用于设置打印细节的窗口。 

2) [Print]按钮 

单击此按钮打印 ST 程序。 
 

[设置步骤] 

(1) 为打印设置好必需的数据后，单击[Print]按钮执行打印。 
 

(打印例子) ST 程序 
 

 



 

 

 

8 - 4       8 - 4 

MELSOFT 
8 打印 

 

8.2 打印 FB 定义 

 

[设置目的] 

打印 FB 定义程序并/或打印 FB 定义的 FB 变量。 

 

[操作步骤] 

选择[Project] → [Print]或单击  (  Ctrl  +  P  )。 

 

[对话框] 
 

 
[说明] 

1) Header 

选中复选框打印 FB 变量。 

2) Body 

选中复选框打印 FB 定义程序。 

从梯形图或列表选择程序格式。默认格式为梯形图。 

3) 附加信息 

选择在打印的 FB 定义程序中是否追加软元件注释和/或声明/注解信息。 

4)  Print  按钮 

单击此按钮打印顺控程序。 
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[设置步骤] 

(1) 选择要打印的 FB 定义。 

从登记到工程的 FB 列表中选择要打印的 FB 定义，并使之高亮显示，然后单击

[Select]按钮。 
 

 
 

(2) 选择要打印的项目(Header、Body)，单击[Print]按钮开始打印。 

 

(打印例子:FB 变量) 
 

 
 

(打印例子:程序) 
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备忘录 
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附录 1 不能作为标识和 FB 名使用的字符串 

下面的字符串不能在功能块编程中作为标识和 FB 名使用。 

软元件名、顺控指令、SFC 指令、应用指令不能用作标识。 

当使用下面任意一个字符串时，都可能导致寄存期间或编译期间发生错误。 
 

 在标签程序中不能使用的字符串 

A 

A、ACJ、ADD、ANB、AND、ANDF、ANDN、ANDP、ANI、ANY、ANY_BIT、ANY_DATE、ANY_DERIVED、 

ANY_ELEMENTARY、ANY_INT、ANY_MAGNITUDE、ANY_NUM、ANY_REAL、ANY_SIMPLE、ANY_STRING、 

ARRAY 

B 

B、BCD(P)、BEND、BIN(P)、BKBCD(P)、BKBIN(P)、BL、BLOCK、BMOV(P)、BOOL、 

BOOL_TO_BYTE(DINT、DWORD、INT、REAL、SINT、UDINT、UINT、USINT、WORD)、 

BYTE(DINT、DWORD、INT、REAL、SINT、TIME、UDINT、UINT、USINT、WORD)_TO_STRING、 

BYTE_TO_BOOL(DINT、DWORD、INT、REAL、SINT、UDINT、UINT、USINT、WORD)、 

B_BCD_TO_DINT(INT、SINT)、BXCH(P)、BYTE 

C C、CAL、CALC、CALCN、CJ、CML(P) 

D 

D、DBCD(P)、DBIN(P)、DBL(P)、DCML(P)、DDEC(P)、DEC(P)、DELTA(P)、DFLT(P)、DGBIN(P)、 

DGRY(P)、DI、DINC(P)、DINT、DINT(P)、DINT_TO_BCD(BOOL、BYTE、DWORD、INT、REAL、SINT、 

TIME、UDINT、UINT、USINT、WORD)、DIV、DMOD、DMOV(P)、DNEG(P)、DWORD、DWORD_TO_BOOL(BYTE、

DINT、INT、REAL、SINT、UDINT、UINT、USINT、WORD)、DX、DXCH(P)、DY、D_BCD_TO_DINT(INT、SINT) 

E 
E、EGF、EGP、EI、EMOV(P)、END、ENEG(P)、EQ、EQ(GE、GT、LE、LIMIT、LT、MAX、MIN、NE、

SEL)_STRING 

F F、FD、FEND、FF、FLT(P)、FMOV(P)、FX、FY 

G G、GBIN(P)、GE、GOEND、GRY(P)、GT 

H H 

I 
I、IMASK、INC(P)、INT、INT(P)、INT_TO_BOOL(BYTE、DINT、DWORD、REAL、SINT、UDINT、UINT、

USINT、WORD)、INV、IRET 

J J、JMP、JMPC、JMPCN 

K K 

L L、LD、LDF、LDI、LDN、LDP、LE、LED、LEDA、LEDB、LEDC、LEDR、LINT、LREAL、LT、LWORD 

M M、MC、MCR、MEF、MEP、MOD、MOV(P)、MPP、MPS、MRD、MTR、MUL 

N N、NE、NEG(P)、NOP、NOPLF、NOT 

O OR、ORB、ORF、ORI、ORN、ORP、OUT(H) 

P P、PAGE、PCHK、PLF、PLS、PLSY、PWM 

Q Q 

R 
R、RAMP、RCJ、READ、REAL、REAL_TO_BOOL(BYTE、DINT、DWORD、INT、SINT、UDINT、UINT、USINT、

WORD)、RECV、REQ、RET、RETC、RETCN、RFRP、RFS、ROTC、RST、RTOP 
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 在标签程序中不能使用的字符串 

S 

S、SB、SCJ、SD、SEND、SET、SFCP、SFCPEND、SFT(P)、SG、SINT、SINT_TO_BOOL(BYTE、DINT、DWORD、

INT、REAL、UDINT、UINT、USINT、WORD)、SM、SPD、SREAD、ST、STEPC、STEPD、STEPG、STEPI、

STEPID、STEPIR、STEPISC、STEPISE、STEPIST、STEPN、STEPR、STEPSC、STEPSE、STEPST、STMR、STN、

STOP、STRING、STRING_TO_BYTE(DINT、DWORD、INT、REAL、SINT、TIME、UDINT、UINT、USINT、WORD)、

SUB、SW、SWAP(P)、SWRITE、SZ 

T 
T、TIME、TR、TRANA、TRANC、TRANCA、TRANCO、TRANCOC、TRANJ、TRANL、TRANO、TRANOA、TRANOC、

TRANOCA、TRANOCJ、TRANOJ、TRUNC_DINT(INT、SINT)、TTMR 

U 

U、UDCNT1(P)、UDCNT2(P)、UDINT、UDINT_TO_BOOL(BYTE、DINT、DWORD、INT、REAL、SINT、UINT、

USINT、WORD)、UINT、UINT_TO_BOOL(BYTE、DINT、DWORD、INT、REAL、SINT、UDINT、USINT、WORD)、

ULINT、USINT、USINT_TO_BOOL(BYTE、DINT、DWORD、INT、REAL、SINT、UDINT、UINT、WORD) 

V 

V、VAR、VAR_CONSTANT、VAR_EXT、VAR_EXTERNAL、VAR_EXTERNAL_CONSTANT、 

VAR_EXTERNAL_FB、VAR_EXTERNAL_PG、VAR_GLOBAL、VAR_GLOBAL_CONSTANT、 

VAR_GLOBAL_FB、VAR_GLOBAL_PG、VAR_IN_OUT、VAR_INPUT、VAR_OUTPUT、VAR_TEMP、VD、VOID 

W 
W、WORD、WORD(P)、WORD_TO_BOOL(BYTE、DINT、DWORD、INT、REAL、SINT、UDINT、UINT、USINT)、 

WRITE、WSTRING、W_BCD_TO_DINT(INT、SINT) 

X X、XCH(P)、XOR、XORN 

Y Y 

Z Z、ZCOM、ZNRD、ZNRF、ZNTO、ZNWR、ZR 

功能组 MELSEC 功能组、IEC 功能组 

 

有有有签名名名名名名 

1. 不不不不不不不不 

2. 不不使不用用用用用用用不不 

3. 以以名不不不不: 

(、)、*、/、+、-、<、>、=、&、!、”、#、$、%、’、^、|、@、[、]、

{、}、;、:、、、.、?、\、_ 

但但、但但不不但但有以但但名用不、但但但现现现现现现现现现现现现但有以但但名用不现

续但现续、续不续续续但续不 

4. 以 0现 F结结名结结结名结续结结但续不 

例例: XFFF、M100 

5. 不不不不“EnDm”用用有作名(例:E001D9)不 

(n和 m 但是名是) 

但但不不但如如名有作名、续不续如如用但如现如用是如不不用用有作名不 
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[B] 

编译 ........................... 3-14，3-31 

变量类型 ............................. 3-11 

标识 ................................. 3-11 

 

[C] 

插入按钮 ............................. 3-12 

查找 

查找步编号. ........................ 3-28 

查找触点或线圈 ..................... 3-28 

查找软元件 ......................... 3-28 

查找指令 ........................... 3-28 

查找字符串 ......................... 3-28 

交叉参阅列表 ....................... 3-30 

已使用的软元件列表 ................. 3-28 

常数 ............................ 3-8，3-11 

程序 body.............................. 1-2 

 

[D] 

打印 

打印 FB 定义 ......................... 8-6 

打印顺控程序 ........................ 8-1 

读取于 PLC............................ 3-36 

 

[F] 

FB .................................... 1-1 

FB 变更模块地址....................... 3-23 

FB 变量................................ 1-3 

FB 变量设置窗口........................ 1-3 

FB 标签................................ 1-2 

FB 窗口................................ 1-4 

FB 定义................................ 1-2 

FB 定义程序............................ 1-2 

FB 定义窗口............................ 1-2 

FB 定义名.............................. 1-4 

FB 利用............................... 3-16 

FB 名.................................. 1-4 

FB 区.................................. 1-4 

 

[G] 

工程 .................................. 3-3 

工程标签 .............................. 1-4 

 

 

 

 

[I] 

I/O 变量......................... 3-8，3-11 

 

[J] 

监视 ................................. 3-38 

 

[M] 

命令按钮 ............................. 4-10 

 

[R] 

软元件测试 ........................... 3-41 

软元件类型 ........................... 3-12 

BOOL ............................... 3-12 

DINT ............................... 3-12 

INT ................................ 3-12 

REAL ............................... 3-12 

STRING ............................. 3-12 

 

[S] 

删除按钮 ............................. 3-12 

声明 ................................. 3-30 

输出变量 ........................ 3-8，3-11 

输出梯形图区 ......................... 3-21 

输入变量 ........................ 3-8，3-11 

输入梯形图区 ......................... 3-21 

顺控程序窗口 .................... 1-3，3-28 

 

[T] 

替换 

变更打开/关闭触点 .................. 3-28 

变更模块开始地址 ................... 3-28 

替换软元件 ........................... 3-28 

替换声明/注解类型 .................... 3-28 

替换指令 ............................. 3-28 

替换字符串 ........................... 3-28 

添加按钮 ............................. 3-12 

 

[X] 

写入至 PLC............................ 3-37 
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[Y] 

在线程序修正 ......................... 3-44 

注解 ................................. 3-30 

注释 ........................... 3-12，3-30 

自动分配 ............................. 3-13 

自动设置软元件 ....................... 3-13 
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Microsoft Windows、Microsoft Windows NT 是微软公司在美国及其它国家的注册商标。 

Pentium 是英特尔公司在美国及其它国家的注册商标。 

本手册中使用的其它公司名和产品名是各自公司的商标或注册商标。 
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